INKSCAPE

Inkscape Tutorial 1: Basics

This tutorial demonstrates the basics of using Inkscape.

The Basic Tutorial covers canvas navigation, managing documents, shape
tool basics, selection techniques, transforming objects with selector,
grouping, setting fill and stroke, alignment, and z-order. For more advanced
topics, check out the other tutorials in the Inkscape Help menu.

Panning the canvas

There are many ways to pan (scroll) the document canvas. Try Ctrl+arrow
keys to scroll by keyboard. You can also drag the canvas by the middle
mouse button. Or, you can use the scrollbars (press ctrl+B to show or hide
them). The wheel on your mouse also works for scrolling vertically; press Shift
with the wheel to scroll horizontally.

TRY IT: TRY THE WAYS TO PAN AN IMAGE NOW

Zooming in or out

The easiest way to zoom is by pressing - and + (or =) keys. You can also use
Ctrl+middle click Or Ctrl+right click to zoom in, Shift+middle click Or Shift+right click to
zoom out, or rotate the mouse wheel with ctrl. Or, you can click in the zoom
entry field (in the bottom left corner of the document window), type a
precise zoom value in %, and press Enter. We also have the Zoom tool

(in the toolbar on left) which lets you to zoom into an area by dragging
around it.

TRY IT: TRY THE WAYS TO ZOOM A IMAGE NOW
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The vertical toolbar on the left shows Inkscape's drawing and editing tools.
In the top part of the window, below the menu, there's the Commands bar
with general command buttons and the Tool Controls bar with controls that
are specific to each tool. The status bar at the bottom of the window wiill
display useful hints and messages as you work.

Many operations are available through keyboard shortcuts. Open Help >
Keys and Mouse to see the complete reference.

TRY IT: EXPLORE THE VARIOUS DRAWING TOOLS SHOWN TO THE
LEFT

Creating and managing documents

To create a new empty document, use File > New or press Ctrl+N. To open
an existing SVG document, use File = Open (Ctrl+0). To save, use File >
Save (Ctrl+S), or Save As (Shift+Ctrl+S) to save under a new name. (Inkscape
may still be unstable, so remember to save often!)

Inkscape uses the SVG (Scalable Vector Graphics) format for its files. SVG is
an open standard widely supported by graphic software. SVG files are based
on XML and can be edited with any text or XML editor (apart from Inkscape,
that is). Besides SVG, Inkscape can import and export several other formats
(EPS, PNG).

Inkscape opens a separate document window for each document. You can
navigate among them using your window manager (e.g. by Alt+Tab), or you
can use the Inkscape shortcut, Ctrl+Tab, which will cycle through all open
document windows. (Create a new document now and switch between it and
this document for practice.)

TRY IT: CREATE A NEW DOCUMENT
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Creating shapes

Time for some nice shapes! Click on the Rectangle tool in the toolbar |:|
(or press F4) and click-and-drag, in your new empty document.

As you can see, default rectangles come up blue, with a black stroke
(outline), and partly transparent. We'll see how to change that below. With
other tools, you can also create ellipses, stars, and spirals:
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These tools are collectively known as shape tools. Each shape you create
displays one or more diamond-shaped handles; try dragging them to see
how the shape responds.

TRY IT: DRAW A RECTANGLE, AN ELLIPSE, A STAR, AND A SPIRAL.

The Controls panel (the second toolbar from the top) for a shape tool is
another way to tweak a shape; these controls affect the currently selected
shapes (i.e. those that display the handles) and set the default that will
apply to newly created shapes.

The Controls panel for a selected rectangle looks like this:
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TRY IT: USE THE CONTROLS PANEL TO CHANGE THE SIZE AND
POSITION OF A RECTANGLE. TO DO THIS, CHANGE THE X (POSITION
LEFT OR RIGHT), Y (POSITION UP OR DOWN), W (WIDTH), AND/OR
H (HEIGHT) FIELDS.
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FYI: To undo your last action, press ctrl+z. (Or, if you change your mind
again, you can redo the undone action by Shift+Ctrl+2Z.)

Moving, scaling, rotating

The most frequently used Inkscape tool is the Selector. Click the topmost
button (with the arrow) on the toolbar, or press F1 or Space. A
Now you can select any object on the canvas.

TRY IT: TRY SELECTING AN OBJECT

You will see eight arrow-shaped handles appear around the object. Now you
can:

e Move the object by dragging it. (Press Ctrl to restrict movement to
horizontal and vertical.)

e Scale the object by dragging any handle. (Press ctrl to preserve the
original height/width ratio.)

Now click the rectangle again. The handles change. Now you can:

« Rotate the object by dragging corner handles. (Press Ctrl to restrict
rotation to 15 degree steps. Drag the cross mark to position the center
of rotation.)

e Skew (shear) the object by dragging non-corner handles. (Press Ctrl to
restrict skewing to 15 degree steps.)

While in Selector, you can also use the numeric entry fields in the Controls
bar (above the canvas) to set exact values for coordinates (X and Y) and
size (W and H) of the selection.

TRY IT: TRY MOVING AND OBJECT AND THE ROTATE IT
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Transforming by keys

One of Inkscape's features that set it apart from most other vector editors is
its emphasis on keyboard accessibility. There's hardly any command or
action that is impossible to do from keyboard, and transforming objects is no
exception.

You can use the keyboard to move (arrow keys), scale (< and > keys), and
rotate ([ and ] keys) objects. Default moves and scales are by 2 px; with
Shift, you move or scale by 10 times that. Ctrl+> and Ctrl+< scale up or down
to 200% or 50% of the original, respectively. Default rotates are by 15
degrees; with ctrl, you rotate by 90 degrees.

However, perhaps the most useful are pixel-size transformations, invoked by
using Alt with the transform keys. For example, Alt+arrows will move the
selection by 1 pixel at the current zoom (i.e. by 1 screen pixel, not to be
confused with the px unit which is an SVG length unit independent of zoom).
This means that if you zoom in, one Alt+arrow will result in a smaller absolute
movement which will still look like one-pixel nudge on your screen. It is thus
possible to position objects with arbitrary precision simply by zooming in or
out as needed.

TRY 1T: MOVE AN OBJECT AROUND USING THE VARIOUS KEYBOARD
SHORTCUTS.

Similarly, Alt+> and Alt+< scale selection so that its visible size changes by
one screen pixel, and Alt+[ and Alt+] rotate it so that its farthest-from-center
point moves by one screen pixel.

Multiple selections

You can select any number of objects simultaneously by Shift+clicking them.
Or, you can drag around the objects you need to select; this is called
rubberband selection. (Selector creates rubberband when dragging from an
empty space; however, if you press shift before starting to drag, Inkscape
will always create the rubberband.)

TRY IT: USE THE RUBBERBAND TO SELECT TWO OBJECTS

Each individual object within a selection displays a selection cue by default, a
dashed rectangular frame. These cues make it easy to see at once what is
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selected and what is not. shift+clicking on a selected object excludes it from
the selection.

TRY IT: SELECT THREE OBJECTS AND THEN USE SHIFT-CLICK TO
DESELECT ONE.

Pressing Esc deselects any selected objects. Ctrl+A selects all objects in the
current layer (if you did not create layers, this is the same as all objects in
the document).

Grouping

Several objects can be combined into a group. A group behaves as a single
object when you drag or transform it.

To create a group, you select one or more objects and press Ctrl+G (OR
SELECT OBJECT > GROUP FROM THE MENU). TO ungroup one or more groups,
select them and press Ctrl+U (OR SELECT OBJECT > UNGROUP FROM THE MENU).
Groups themselves may be grouped, just like any other objects. However,
ctrl+U only ungroups the topmost level of grouping in a selection; you'll need
to press Ctrl+U repeatedly if you want to completely ungroup a deep group-
in-group.

You don't necessarily have to ungroup, however, if you want to edit an
object within a group. Just Ctri+click that object and it will be selected and
editable alone, or shift+Ctrl+click several objects (inside or outside any
groups) for multiple selection regardless of grouping.

TRY IT: SELECT SEVERAL SHAPES THEN GROUP THEM. ONCE
GROUPED, MOVE THE ENTIRE GROUP SOMEPLACE ELSE.

TRY IT: CTRL-CLICK AN OBJECT IN YOUR GROUP TO MOVE IT BY
ITSELF.

Fill and stroke

Many of Inkscape's functions are available via dialogs. Probably the simplest
way to paint an object some color is to open the Swatches dialog from the
View menu, select an object, and click a swatch to paint it (change its fill
color).
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TRY IT: USE THE SWATCHES DIALOG TO CHANGE THE COLOR OF AN
OBJECT

More powerful is the Fill and Stroke dialog (shift+Ctrl+F or Objects > Fill and
Stroke from the menu).

TRY IT: SELECT A SHAPE AND OPEN THE FILL AND STROKE DIALOG.

You will see that the dialog has three tabs: Fill, Stroke paint, and Stroke
style. The Fill tab lets you edit the fill (interior) of the selected object(s).
Using the buttons just below the tab, you can select types of fill, including no
fill (the button with the X), flat color fill, as well as linear or radial gradients.
For the above shape, the flat fill button will be activated.

Further below, you see a collection of color pickers, each in its own tab:
RGB, CMYK, HSL, and Wheel. Perhaps the most convenient is the Wheel
picker, where you can rotate the triangle to choose a hue on the wheel, and
then select a shade of that hue within the triangle. All color pickers contain a
slider to set the alpha (opacity) of the selected object(s).

TRY IT: USE THE WHEEL COLOR PICKER TO CHANGE THE COLOR OF
YOUR SELECTED OBJECT.

Whenever you select an object, the color picker is updated to display its
current fill and stroke (for multiple selected objects, the dialog shows their
average color).

TRY IT: SELECT OTHER OBJECTS AND WATCH THE COLOR PICKER
CHANGE.

Using the Stroke paint tab, you can remove the stroke (outline) of the
object, or assign any color or transparency to it:

TRY IT: CHANGE THE COLOR OF THE STROKE (OUTLINE) OF YOUR
CURRENTLY SELECTED OBJECT
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The last tab, Stroke style, lets you set the width and other parameters of the
stroke:
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Finally, instead of flat color, you can use gradients for fills and/or strokes by
selecting one of the gradient options as shown below:

IAFill and Stroke (Shift-+Ctrl+F)

Fil I 'stroke paint EStr’DkE style
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Flat color
RGE | HSL| Chyk | Wheel | CMS
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When you switch from flat color to gradient, the newly created gradient uses
the previous flat color, going from opaque to transparent. Switch to the
Gradient tool (ctrl+F1) to drag the gradient handles the controls connected
by lines that define the direction and length of the gradient. When any of the
gradient handles is selected (highlighted blue), the Fill and Stroke dialog
sets the color of that handle instead of the color of the entire selected
object.

TRY IT: CHANGE YOUR CURRENTLY SELECT OBJECT TO BE FILLED
WITH A GRADIENT AND PLAY AROUND WITH THE VARIOUS
OPTIONS.

Yet another easy way to change a color of an object is by using the Dropper f
tool (F7). Just click anywhere in the drawing with that tool, and the picked

color will be assigned to the selected object's fill (shift+click will assign stroke
color).

TRY IT: CHANGE THE COLOR OF THE CURRENTLY SELECTED OBJECT
TO THE COLOR OF ANOTHER OBJECT USING THE DROPPER TOOL.
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Duplication, alignment, distribution

One of the most common operations is duplicating an object (Ctrl+D — or Edit >
Duplicate from the menu). The duplicate is placed exactly above the original and
is selected, so you can drag it away by mouse or by arrow keys.

TRY IT: SELECT AN OBJECT AND DUPLICATE IT. MOVE THE
DUPLICATE USING THE MOUSE OR THE ARROW KEYS.

Chances are your copies of the object are placed pretty randomly. This is
where the Align dialog (Ctrl+Shift+A — or Object > Align and Distribute from the menu)
is useful.

TRY IT: SELECT ALL THE OBJECTS (SHIFT+CLICK OR DRAG A
RUBBERBAND), OPEN THE DIALOG AND PRESS THE "CENTER ON
HORIZONTAL AXIS™ BUTTON, THEN THE "MAKE HORIZONTAL GAPS
BETWEEN OBJECTS EQUAL'™ BUTTON (READ THE BUTTON TOOLTIPS).
THE OBJECTS ARE NOW NEATLY ALIGNED AND DISTRIBUTED
EVENLY.

Z-order

The term z-order refers to the stacking order of objects in a drawing, i.e. to
which objects are on top and obscure others. The two commands in the
Object menu, Raise to Top (the Home key) and Lower to Bottom (the End
key), will move your selected objects to the very top or very bottom of the
current layer's z-order. Two more commands, Raise (Pgup) and Lower (PgDn),
will sink or emerge the selection one step only, i.e. move it past one non-
selected object in z-order (only objects that overlap the selection count; if
nothing overlaps the selection, Raise and Lower move it all the way to the
top or bottom correspondingly).

TRY 1T: MOVE ONE OBJECT PARTIALLY OVER ANOTHER OBJECT AND
CHANGE THE Z-ORDER MY USING ONE OF THE METHODS LISTED
ABOVE.
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You also can change the z-order by selecting one of these buttons 1= =
from the Tools Control toolbar (second from the top)
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Selecting under and dragging selected

What to do if the object you need is hidden behind another object? You may
still see the bottom object if the top one is (partially) transparent, but
clicking on it will select the top object, not the one you need.

This is what Alt+click is for. First Alt+click selects the top object just like the
regular click. However, the next Alt+click at the same point will select the
object below the top one; the next one, the object still lower, etc. Thus,
several Alt+clicks in a row will cycle, top-to-bottom, through the entire z-
order stack of objects at the click point. When the bottom object is reached,
next Alt+click will, naturally, again select the topmost object.

TRY IT: MOVE AN OBJECT TO BE COMPLETELY HIDDEN BY ANOTHER
OBJECT. USE THE ALT-CLICK METHOD TO SELECT THE BOTTOM
OBJECT.

This is nice, but once you selected an under-the-surface object, what can
you do with it? You can use keys to transform it, and you can drag the
selection handles. However, dragging the object itself will reset the selection
to the top object again (this is how click-and-drag is designed to work a€” it
selects the (top) object under cursor first, then drags the selection). To tell
Inkscape to drag what is selected now without selecting anything else, use
Alt+drag. This will move the current selection no matter where you drag your
mouse.

TRY 1T: MOVE THE HIDDEN OBJECT THAT YOU SELECTED LAST TIME
USING THE ALT-DRAG METHOD.

Conclusion

This concludes the Basic tutorial. There's much more than that to Inkscape,
but with the techniques described here, you will already be able to create
simple yet useful graphics. For more complicated stuff, go through the
Advanced and other tutorials in Help > Tutorials.

GO TO THE NEXT PAGE FOR INSTRUCTIONS ON TURNING THIS TUTORIAL
IN.
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TURN YOUR IMAGE IN NOW.

When you have completed this tutorial, put your name and period on the
image file(s) you have created, print it out, and hand it in. Your image(s)
should include:

1. Several shapes including rectangles (of various colors), an ellipse, a
star, and a spiral.

A shape that is rotated.

A grouped set of objects

An object filled with a gradient

At least two overlapping shapes

o h N

This is for a grade, so if you are missing any of these, find the step you
missed and redo it.
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